云引擎 1.0 运行环境下线通知

我们计划于 2015 年 12 月 1 日零时 ,将版本较低的云引擎 1.0 运行环境下线。届时所有使用云引擎 1.0 运行环境的应用在请求云引擎时将收到错误响应,所有云引擎相关的 hook 函数将不可用,这可能会影响到其他服务(如存储、实时通信)。因此,请使用 1.0 版本的用户提前做好测试,尽快按下面的说明完成升级,以免给最终用户带来影响。

我们最新的云引擎版本为 3.0,于 2015 年 5 月推出,其主要特性是「去沙箱」和「支持 Python 运行时」。没有沙箱环境使得在云引擎上可以运行标准的 Node.js 项目,支持任意的 Web 框架,项目开发调试会更加灵活。这些都使得 3.0 在性能和功能上较其前任们有很大的提升, 因此我们推荐用户升级到最新的 3.0 版本。

由于技术跨度较大,我们不支持从 1.0 直接升级到 3.0,所以 1.0 需要先升级到 2.0 后再升级到 3.0。

下线时间

2015 年 12 月 1 日 0:00

如何判断是否需要升级

  • 2014 年 8 月 14 号之后创建的应用已不再使用 1.0 环境,因此不需要升级。
  • 登录 LeanCloud 网站控制台,在应用的 云引擎 > Git 部署 页面上方,如果出现「升级到云引擎 2.0」的提示,则表明需要升级。

如何升级

  • 云引擎 1.0 升级到 2.0
    请按照 1.0 至 2.0 升级文档 来更新代码。然后进入应用控制台,点击 云引擎 > Git 部署 页面上方的「升级到 2.0 版本」,之后重新部署应用即可。
  • 云引擎 2.0 升级到 3.0
    请按照 2.0 至 3.0 升级文档 来更新代码。然后进入应用控制台重新部署应用即可,3.0 的应用会自动识别并生效。

如果仍有疑问,请通过论坛或工单系统 与我们联系

发表评论

电子邮件地址不会被公开。 必填项已用*标注